import re
regex = re.compile(r"IO::Memory(O|I)Channel(|32)([\s]|::|&[\s])", flags=re.MULTILINE)
test_str = (" GS::MemoryOChannel32 oBuffer (IO::MemoryOChannel32::BMAllocation);\n\n\n\n"
" BinIProtocol.hpp\n"
" BinOProtocol.hpp\n"
" InputBuffer.hpp\n"
" OutputBuffer.hpp\n"
" IChannelAdapter.hpp\n"
" OChannelAdapter.hpp\n"
" MemoryIChannel.hpp\n"
" MemoryIChannel32.hpp\n"
" MemoryOChannel.hpp\n"
" MemoryOChannel32.hpp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")