package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(http|ftp|https):\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?`)
var str = `http://www.some.com
www.some.com
some.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}