re = /(?:(http|ftp|https):\/\/)?[\w-]+(\.[\w-]+)+([\w.,@?^=%&:\/~+#-]*[\w@?^=%&\/~+#-])?/
str = 'http://www.some.com
www.some.com
some.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end