const regex = /(.*?brown ).*?(l.*)|(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?brown ).*?(l.*)|(.+)', 'g')
const str = `The quick brown fox jumps over the azy dog
The quick brown fox jumps over the lazy dog
`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);