import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)[@$%]|[@$%](?!\\d)";
final String string = "'5%'\n"
+ "'%5'\n"
+ "'5%+3'\n"
+ "'5%%'\n"
+ "333$\n"
+ "2@2\n\n"
+ "4%4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}