re = /(?<!\d)[@$%]|[@$%](?!\d)/m
str = '\'5%\'
\'%5\'
\'5%+3\'
\'5%%\'
333$
2@2
4%4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end