#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b"
Local $sString = "// YES" & @CRLF & _
"WFTDOC_TASK_DOCUMENT_V01" & @CRLF & _
"WFTASK_TASK_V01" & @CRLF & _
"" & @CRLF & _
"// NO" & @CRLF & _
"[WFW].[WFLOW_WORKFLOW_V01]" & @CRLF & _
"WFW.WFTASK_TASK_V01" & @CRLF & _
"Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01" & @CRLF & _
"WORKER_TOKEN_NR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")