import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?<!WFW\\.|\\[WFW\\]\\.\\[)[A-Z_]+_V01)\\b";
final String string = "// YES\n"
+ "WFTDOC_TASK_DOCUMENT_V01\n"
+ "WFTASK_TASK_V01\n\n"
+ "// NO\n"
+ "[WFW].[WFLOW_WORKFLOW_V01]\n"
+ "WFW.WFTASK_TASK_V01\n"
+ "Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01\n"
+ "WORKER_TOKEN_NR";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}