import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\")[23]{1,7}(?=\\\")";
final String string = "\"3\"sca\"\"\"co\"1\"str\"0\"ctor\"\"r\"3\"t\"0\"r\"1\"\"locat\"5\"o\"133\"\"0\"27\"\"754a49b393c2a0\"33\"b97\"332\"cb7\"3\"c3c07\"2\"\"co\"1\"str\"0\"ct\"23322322\"or\"\"r\"3\"t\"0\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}