import re
regex = re.compile(r"(?<=\")[23]{1,7}(?=\")")
test_str = "\"3\"sca\"\"\"co\"1\"str\"0\"ctor\"\"r\"3\"t\"0\"r\"1\"\"locat\"5\"o\"133\"\"0\"27\"\"754a49b393c2a0\"33\"b97\"332\"cb7\"3\"c3c07\"2\"\"co\"1\"str\"0\"ct\"23322322\"or\"\"r\"3\"t\"0\""
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)