re = /^[A-Z]+(?:_[A-Z]+)*(?:\n[A-Z]+(?:_[A-Z]+)*)*$/
str = 'ERIS_TEST_GROUP_NAME
JENNIFER_AD_GROUP_NAME
PSEUDO_TEST_TEAM
TEST_GROUP'
# Print the match result
str.match(re) do |match|
puts match.to_s
end