$re = '/(^[a-zA-Z_][-_a-zA-Z0-9]){0,39}$/';
$str = 'Word';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);