import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([a-z0-9A-Z+\\/]){4})*(?1)(?:(?1)==|(?1){2}=|(?1){3})$";
final String string = "YW55IGNhcm5hbCBwbGVhcw==\n"
+ "YW55IGNhcm5hbCBwbGVhc3U=\n"
+ "YW55IGNhcm5hbCBwbGVhc3Vy\n"
+ "Invalid:\n"
+ "YW5@IGNhcm5hbCBwbGVhcw==\n"
+ "YW55IGNhc=5hbCBwbGVhcw==\n"
+ "YW55IGNhcm5hbCBwbGVhc3V\n"
+ "YW55IGNhcm5hbCBwbGVhc3\n"
+ "YW55IGNhcm5hbCBwbGVhc\n"
+ "YW55IGNhcm5hbCBwbGVh=\n"
+ "YW55IGNhcm5hbCBwbGVhc==\n"
+ "YW55IGNhcm5hbCBwbGVhc===";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}