# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:([a-z0-9A-Z+\/]){4})*(?1)(?:(?1)==|(?1){2}=|(?1){3})$"
test_str = ("YW55IGNhcm5hbCBwbGVhcw==\n"
"YW55IGNhcm5hbCBwbGVhc3U=\n"
"YW55IGNhcm5hbCBwbGVhc3Vy\n"
"Invalid:\n"
"YW5@IGNhcm5hbCBwbGVhcw==\n"
"YW55IGNhc=5hbCBwbGVhcw==\n"
"YW55IGNhcm5hbCBwbGVhc3V\n"
"YW55IGNhcm5hbCBwbGVhc3\n"
"YW55IGNhcm5hbCBwbGVhc\n"
"YW55IGNhcm5hbCBwbGVh=\n"
"YW55IGNhcm5hbCBwbGVhc==\n"
"YW55IGNhcm5hbCBwbGVhc===")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.