$re = '/(\/R(?:C-[A-Z0-9]{2,6})?)(\/[ABCGIKLNPSUV])?/m';
$str = '/R/RC-ABC123
/R
/RC-ABC123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);