re = /(\/R(?:C-[A-Z0-9]{2,6})?)(\/[ABCGIKLNPSUV])?/m
str = '/R/RC-ABC123
/R
/RC-ABC123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end