package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)import(?:["'\s]*([\w*{}\n\r\t, ]+)from\s*)?["'\s].*([@\w_-]+)["'\s].*;$`)
var str = `import {
Component
} from '@angular2/core';
import defaultMember from "module-name";
import * as name from "module-name ";
import { member } from " module-name";
import { member as alias } from "module-name";
import { member1 ,
member2 } from "module-name";
import { member1 , member2 as alias2 , member3 as alias3 } from "module-name";
import defaultMember, { member, member } from "module-name";
import defaultMember, * as name from "module-name";
import "module-name";
import * from './smdn';
/**
*Add all needed dependency to this module
*app requires those import modules to function
**/
let modules = [];
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}