$re = '/import(?:["\'\s]*([\w*{}\n\r\t, ]+)from\s*)?["\'\s].*([@\w_-]+)["\'\s].*;$/m';
$str = 'import {
Component
} from \'@angular2/core\';
import defaultMember from "module-name";
import * as name from "module-name ";
import { member } from " module-name";
import { member as alias } from "module-name";
import { member1 ,
member2 } from "module-name";
import { member1 , member2 as alias2 , member3 as alias3 } from "module-name";
import defaultMember, { member, member } from "module-name";
import defaultMember, * as name from "module-name";
import "module-name";
import * from \'./smdn\';
/**
*Add all needed dependency to this module
*app requires those import modules to function
**/
let modules = [];
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);