// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}</a></td><td>\d+").unwrap();
let string = "<a href=\"/ip/190.207.169.184/free_Venezuela_proxy_servers_VE_Venezuela\">190.207.169.184</a></td><td>8080</td><td>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}