package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*stuff382689,\d+$`)
var str = `/category/stuff382689,25090
/category/stuff382689,25090,,1
/category/stuff382689,25090,,2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}