const regex = /^(?!^([^#]*#[^#]*){5,}$)(?!(.*http(s{0,1}):\/\/){2,})(?=.*[a-z]).{0,300}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!^([^#]*#[^#]*){5,}$)(?!(.*http(s{0,1}):\\\/\\\/){2,})(?=.*[a-z]).{0,300}$', '')
const str = `aaaa####http://`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}