re = /^(?!^([^#]*#[^#]*){5,}$)(?!(.*http(s{0,1}):\/\/){2,})(?=.*[a-z]).{0,300}$/
str = 'aaaa####http://'
# Print the match result
str.match(re) do |match|
puts match.to_s
end