import Foundation
let pattern = #"(Failed to handle request ).+( on subject.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Failed to handle request 0[null->null s:0 w:0.0 a: 0.0 S:0 t: 24543060 s(NA) (0 0)] on subject RealTimeUpdate
Failed to handle request blablabla on subject RealTimeUpdate
Failed to handle request test0120120120 on subject RealTimeUpdate
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)