import re
regex = re.compile(r"(?!\B\"[^\"]*),(?![^\"]*\"\B)")
test_str = ("bob jones,123,55.6,,,\"Hello , World\",,0\n"
"jim neighbor,432,66.5,,,Andy \"Blank,,1\n"
"john smith,555,77.4,,,Some value,,2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")