const regex = /(?|(Subject\(.*\)_)|(_Date.*))/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(Subject\\(.*\\)_)|(_Date.*))', 'ig')
const str = `Subject(учебники Разумник)_Разумник_наличие_Date(Mon, 16 Jan 2017 13_37_50 +0300).zip`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}