re = /(?|(Subject\(.*\)_)|(_Date.*))/i
str = 'Subject(учебники Разумник)_Разумник_наличие_Date(Mon, 16 Jan 2017 13_37_50 +0300).zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end