package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http(s)??\:\/\/)?(www\.)?((youtube\.com\/watch\?v=)|(youtu.be\/))([a-zA-Z0-9\-_])+$`)
var str = `https://www.youtube.com/watch?v=
https://www.youtube.com/watch?v=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}