$re = '/(^.*?\.com\/)(?:.*?)(\?utm.*$)/m';
$str = 'https://www.forexample.com/cat.belt?utm2900&eav=AfbHJya2K7Mbg2mPWatN';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;