// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^.*?\.com\/)(?:.*?)(\?utm.*$)").unwrap();
let string = "https://www.forexample.com/cat.belt?utm2900&eav=AfbHJya2K7Mbg2mPWatN";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}