#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?://(?|media\.giphy\.com/media/([^ /\n]+)/giphy\.gif|i\.giphy\.com/([^ /\n]+)\.gif|giphy\.com/gifs/(?:.*-)?([^ /\n]+))"
Local $sString = "http://i.giphy.com/VmzI60RQG0fuw.gif" & @CRLF & _
"https://media.giphy.com/media/VmzI60RQG0fuw/giphy.gif" & @CRLF & _
"http://giphy.com/gifs/music-videos-mariah-carey-dreamlover-VmzI60RQG0fuw" & @CRLF & _
"http://giphy.com/gifs/VmzI60RQG0fuw" & @CRLF & _
"http://giphy.com/gifs/sbYP9PtdaRVsY/html5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")