using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(?|media\.giphy\.com/media/([^ /\n]+)/giphy\.gif|i\.giphy\.com/([^ /\n]+)\.gif|giphy\.com/gifs/(?:.*-)?([^ /\n]+))";
string input = @"http://i.giphy.com/VmzI60RQG0fuw.gif
https://media.giphy.com/media/VmzI60RQG0fuw/giphy.gif
http://giphy.com/gifs/music-videos-mariah-carey-dreamlover-VmzI60RQG0fuw
http://giphy.com/gifs/VmzI60RQG0fuw
http://giphy.com/gifs/sbYP9PtdaRVsY/html5";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}