package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\bhttps?::\/\/\S+`)
var str = `hei dude, check this link http:://google.com and http:://youtube.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}