$re = '/\bhttps?::\/\/\S+/i';
$str = 'hei dude, check this link http:://google.com and http:://youtube.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);