package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`class=["']\bcustom--week is-active\b.*?range["]>(.*?)<\/`)
var str = `<div class="Week__wrapper"><div class="custom--week"><a href="/nfl/schedule/_/week/2/year/2024/seasontype/1" tabindex="0"><span class="week week-range">Pre wk 1</span><span class="week">Aug 8 - 14</span></a></div><div class="custom--week"><a href="/nfl/schedule/_/week/3/year/2024/seasontype/1" tabindex="0"><span class="week week-range">Pre wk 2</span><span class="week">Aug 15 - 21</span></a></div><div class="custom--week"><a href="/nfl/schedule/_/week/4/year/2024/seasontype/1" tabindex="0"><span class="week week-range">Pre wk 3</span><span class="week">Aug 22 - Sep 3</span></a></div><div class="custom--week is-active"><a href="/nfl/schedule/_/week/1/year/2024/seasontype/2" tabindex="0"><span class="week week-range">Week 1</span><span class="week">Sep 4 - 10</span></a></div><div class="custom--week"><a href="/nfl/schedule/_/week/2/year/2024/seasontype/2" tabindex="0"><span class="week week-range">Week 2</span><span class="week">Sep 11 - 17</span></a></div><div class="custom--week"><a href="/nfl/schedule/_/week/3/year/2024/seasontype/2" tabindex="0"><span class="week week-range">Week 3</span><span class="week">Sep 18 - 24</span></a></div><div class="custom--week"><a href="/nfl/schedule/_/week/4/year/2024/seasontype/2" tabindex="0"><span class="week week-range">Week 4</span><span class="week">Sep 25 - Oct 1</span></a></div></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}