import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class=[\"']\\bcustom--week is-active\\b.*?range[\"]>(.*?)<\\/";
final String string = "<div class=\"Week__wrapper\"><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/2/year/2024/seasontype/1\" tabindex=\"0\"><span class=\"week week-range\">Pre wk 1</span><span class=\"week\">Aug 8 - 14</span></a></div><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/3/year/2024/seasontype/1\" tabindex=\"0\"><span class=\"week week-range\">Pre wk 2</span><span class=\"week\">Aug 15 - 21</span></a></div><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/4/year/2024/seasontype/1\" tabindex=\"0\"><span class=\"week week-range\">Pre wk 3</span><span class=\"week\">Aug 22 - Sep 3</span></a></div><div class=\"custom--week is-active\"><a href=\"/nfl/schedule/_/week/1/year/2024/seasontype/2\" tabindex=\"0\"><span class=\"week week-range\">Week 1</span><span class=\"week\">Sep 4 - 10</span></a></div><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/2/year/2024/seasontype/2\" tabindex=\"0\"><span class=\"week week-range\">Week 2</span><span class=\"week\">Sep 11 - 17</span></a></div><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/3/year/2024/seasontype/2\" tabindex=\"0\"><span class=\"week week-range\">Week 3</span><span class=\"week\">Sep 18 - 24</span></a></div><div class=\"custom--week\"><a href=\"/nfl/schedule/_/week/4/year/2024/seasontype/2\" tabindex=\"0\"><span class=\"week week-range\">Week 4</span><span class=\"week\">Sep 25 - Oct 1</span></a></div></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}