package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*$`)
var str = `admin
l0v3y0oplj
123admin
123ADMIN?
123ADMIN
am.ouy?
12345678909776apouatgb
1ads967bjk
ADMIN123
123
,;/.;..,,;.#$¨$#¨%
!@#$%3333333333333333333332`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}