// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9]*[a-zA-Z]+[a-zA-Z0-9]*$").unwrap();
let string = "admin
l0v3y0oplj
123admin
123ADMIN?
123ADMIN
am.ouy?
12345678909776apouatgb
1ads967bjk
ADMIN123
123
,;/.;..,,;.#$¨$#¨%
!@#$%3333333333333333333332";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}