use strict;
my $str = 'hello this is paragragph and this is image 1
<img src=\'https://www.google.co.id/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png\' style=\'width:150px;heigh:150px\'>
this is text and this is image 2
<img src=\'http://www.bing.com/az/hprichbg/rb/HumpbackWhaleReunion_ROW11050338497_1366x768.jpg\' style=\'width:150px;heigh:150px\' ></p>';
my $regex = qr/width:[0-9]+[a-z]{2};?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}