$re = '/width:[0-9]+[a-z]{2};?/i';
$str = 'hello this is paragragph and this is image 1
<img src=\'https://www.google.co.id/images/branding/googlelogo/1x/googlelogo_color_272x92dp.png\' style=\'width:150px;heigh:150px\'>
this is text and this is image 2
<img src=\'http://www.bing.com/az/hprichbg/rb/HumpbackWhaleReunion_ROW11050338497_1366x768.jpg\' style=\'width:150px;heigh:150px\' ></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);