using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(^#|#\1)\d+)+$";
string input = @"#123
#12##235
#1234##12###368
#1234##12###368####22235#####723356
#123#123#123#123
##123
#123###456
#123##456##789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}