$re = '/(?:(^#|#\1)\d+)+$/m';
$str = '#123
#12##235
#1234##12###368
#1234##12###368####22235#####723356
#123#123#123#123
##123
#123###456
#123##456##789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);