#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?:" & @CRLF & _
"" & @CRLF & _
"# Apr - Dec, 1999" & @CRLF & _
"(?:(?:(?:0?\d|[12]\d|3[01])\/(?:0?[578]|1[02]))|(?:(?:0?\d|[12]\d|30)\/(?:0?[469]|11))|(?:(?:0?\d|1\d|2[0-8])\/0?2))\/1999" & @CRLF & _
"" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# 2000 - 2003" & @CRLF & _
"(?:(?:(?:0?\d|[12]\d|3[01])\/(?:0?[13578]|1[02]))|(?:(?:0?\d|[12]\d|30)\/(?:0?[469]|11))|(?:(?:0?\d|1\d|2[0-8])\/0?2))\/200[0-3]" & @CRLF & _
"" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Jan - Mar, 2004" & @CRLF & _
"(?:(?:(?:0?\d|[12]\d|3[01])\/(?:0?[13]))|(?:(?:0?\d|1\d|2[0-8])\/0?2))\/2004" & @CRLF & _
"" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Leap years!" & @CRLF & _
"29\/0?2\/200[04]" & @CRLF & _
"" & @CRLF & _
")$"
Local $sString = "01/04/1999" & @CRLF & _
"31/03/1999" & @CRLF & _
"" & @CRLF & _
"29/02/2000" & @CRLF & _
"30/02/2000" & @CRLF & _
"" & @CRLF & _
"28/2/2001" & @CRLF & _
"29/2/2001" & @CRLF & _
"" & @CRLF & _
"30/4/2002" & @CRLF & _
"31/4/2002" & @CRLF & _
"" & @CRLF & _
"31/1/2003" & @CRLF & _
"32/1/2003" & @CRLF & _
"" & @CRLF & _
"31/3/2004" & @CRLF & _
"01/4/2004"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")