import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\n\n"
+ "# Apr - Dec, 1999\n"
+ "(?:(?:(?:0?\\d|[12]\\d|3[01])\\/(?:0?[578]|1[02]))|(?:(?:0?\\d|[12]\\d|30)\\/(?:0?[469]|11))|(?:(?:0?\\d|1\\d|2[0-8])\\/0?2))\\/1999\n\n"
+ "|\n\n"
+ "# 2000 - 2003\n"
+ "(?:(?:(?:0?\\d|[12]\\d|3[01])\\/(?:0?[13578]|1[02]))|(?:(?:0?\\d|[12]\\d|30)\\/(?:0?[469]|11))|(?:(?:0?\\d|1\\d|2[0-8])\\/0?2))\\/200[0-3]\n\n"
+ "|\n\n"
+ "# Jan - Mar, 2004\n"
+ "(?:(?:(?:0?\\d|[12]\\d|3[01])\\/(?:0?[13]))|(?:(?:0?\\d|1\\d|2[0-8])\\/0?2))\\/2004\n\n"
+ "|\n\n"
+ "# Leap years!\n"
+ "29\\/0?2\\/200[04]\n\n"
+ ")$";
final String string = "01/04/1999\n"
+ "31/03/1999\n\n"
+ "29/02/2000\n"
+ "30/02/2000\n\n"
+ "28/2/2001\n"
+ "29/2/2001\n\n"
+ "30/4/2002\n"
+ "31/4/2002\n\n"
+ "31/1/2003\n"
+ "32/1/2003\n\n"
+ "31/3/2004\n"
+ "01/4/2004";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}