#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bCOLOR="[a-zA-Z]+(?=[^\n"]*")"
Local $sString = "COLOR="WHITE 화이트", DETAIL="NONE"" & @CRLF & _
"SLEEVE="SHORT 쇼트", COLOR="BLUE"" & @CRLF & _
"SLEEVE="LONG", COLOR="GRAY", TOP="DOUBLE"" & @CRLF & _
"COLOR="YELLOW 노랑"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")