import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bCOLOR=\"[a-zA-Z]+(?=[^\\n\"]*\")";
final String string = "COLOR=\"WHITE 화이트\", DETAIL=\"NONE\"\n"
+ "SLEEVE=\"SHORT 쇼트\", COLOR=\"BLUE\"\n"
+ "SLEEVE=\"LONG\", COLOR=\"GRAY\", TOP=\"DOUBLE\"\n"
+ "COLOR=\"YELLOW 노랑\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}