const regex = /^(?=[^A-Z\r\n]*[A-Z])(?=(?:[^\d\r\n]*\d){2})\S+\$$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^A-Z\\r\\n]*[A-Z])(?=(?:[^\\d\\r\\n]*\\d){2})\\S+\\$$', 'gm')
const str = `4hg5Fjkjk\$
fh@#Y5fFF5\$
hgH5Hu6\$
These should not be valid:
45tyghisu\$
5THygfhy\$
Gh%hF45\$h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}