re = /^(?=[^A-Z\r\n]*[A-Z])(?=(?:[^\d\r\n]*\d){2})\S+\$$/m
str = '4hg5Fjkjk$
fh@#Y5fFF5$
hgH5Hu6$
These should not be valid:
45tyghisu$
5THygfhy$
Gh%hF45$h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end