re = /(?:.*\(\d{4}\)\.\s)([^.]*\.)(?: .*)/
str = 'Parikka, J. (2010). Insect Media: An Archaeology of Animals and Technology. Minneapolis: Univ Of Minnesota Press.
Sanders, E. B.-N., Brandt, E., & Binder, T. (2010). A framework for organizing the tools and techniques of participatory design. In Proceedings of the 11th biennial participatory design conference (pp. 195–198). ACM. Retrieved from http://dl.acm.org/citation.cfm?id=1900476
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end