#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "mongoDb: \(variable, subs, value, data\) \{(?<code>(.|\s)*)}"
Local $sString = "mongoDb: (variable, subs, value, data) {" & @CRLF & _
" let key = "my" + '-index';" & @CRLF & _
" let val = arr[key] || "NOPE";" & @CRLF & _
" let parity = (val % 2 == 0) ? "even" : "odd";" & @CRLF & _
" function poly (x){" & @CRLF & _
" arr.map(i => i*2);" & @CRLF & _
" return x^2 + 3*x + Math.PI / 2;" & @CRLF & _
" }" & @CRLF & _
"}," & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")