using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mongoDb: \(variable, subs, value, data\) \{(?<code>(.|\s)*)}";
string input = @"mongoDb: (variable, subs, value, data) {
let key = ""my"" + '-index';
let val = arr[key] || ""NOPE"";
let parity = (val % 2 == 0) ? ""even"" : ""odd"";
function poly (x){
arr.map(i => i*2);
return x^2 + 3*x + Math.PI / 2;
}
},
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}